Runtime errors when clicking Form links
Incident Report for Formstack For Salesforce
Postmortem

Timeframe:

The issue started at 7:30 AM ET and was resolved at 9:55 AM ET.

Cause:

Authentication to one of our Azure back end services was interrupted due to an unexpected update.
Impact:

The impact on the customer was significant:

  • All customers on Classic were unable to access their forms, publish a form, consult the form preview, or make submissions
  • Customers on Native Cloud were mostly not impacted by this issue
  • Customers with cloud storage configured couldn’t receive submissions
  • All customers could still consult existing submission data
Posted Aug 01, 2022 - 14:07 EDT

Resolved
After extensive monitoring, we are confident all functions have returned to normal. Thank you for your patience and understanding!
Posted Aug 01, 2022 - 10:39 EDT
Monitoring
We have pushed a fix and are monitoring to confirm that all functions are operating normally.
Posted Aug 01, 2022 - 09:58 EDT
Identified
We are aware that Classic users are experiencing Runtime Error messages when clicking links. Native Cloud users are not affected, unless they are using an external Cloud provider through the application. We have identified what we believe to be the root cause of the issue, and are working towards issuing a fix. We will update once we have verified that the fix is in place.
Posted Aug 01, 2022 - 09:46 EDT
This incident affected: Hosted Forms and Embedded Forms.